Applications, Tutoriel, Windows 10

[Tuto] Installer des applications Android sur Windows 10 Mobile

28093 views 35 Comments

Nokians.fr et moi même ne seront pas tenus responsable de tout dégât éventuels pouvant être causés par les manipulations proposées.

Android app sur WP

 

Vous n’êtes pas sans savoir que Microsoft vient de nous sortir un petit logiciel open source miracle qui permet « d’exporter » des applications de la plateforme iOS ou Android vers Windows 10 Mobile. Bien entendu, c’est encore une Beta et n’a pas encore les fonctions d’une version finale !

L’équipe de WPMU, nous propose un petit tuto sur l’installation de fichiers APK sur notre téléphone sous Windows 10. En bref, les téléphones compatibles sont ceux qui ont 1 Go de RAM. Le tutoriel nécessitera un PC sous Windows et deux fichiers : et de un et de deux.

Dans le tuto WPMU, ils nous affirment que les applications qui demandent des services Google ne fonctionnent pas. Et…Bien, il y a un petit logiciel qui permet de supprimer les services Google des APK :P. C’est Gmaps Patcher . D’après les commentaires des personnes, nous pouvons faire tourner jusqu’à Snapchat et Clash of Clans ( deux poids lourds du monde des smartphones ) Windows Phone est sauvé 😀 !

Le tuto

En bref, Nous n’avons qu’une petite dizaine de manipulations simples et rapides. Il est, bien entendu, nécessaire d’avoir Windows 10 Mobile.

1/ Décompressez le fichiers sur votre bureau. ( 10 secondes )

2/ Ouvrez le dossier WConnect téléchargé juste avant. Vous y installerez IpOverUsbInstaller.msi ainsi que vcredist_x86.exe. ( 30 secondes )

3/ Ensuite, nous devons activer le mode Dev sur notre Lumia. Paramètres > Mise à jour et sécurité > Pour les développeurs. Cochez la case « Mode Developpeur » et aussi activez la « Detection d’appareils ». ( 30 secondes )

4/ Ouvrez un CMD mais pas de la manière traditionnelle. Allez dans le dossier WConnect extrait auparavant et faites Maj + Clic droit et Ouvrir une fenêtre de commande ici ( 5 secondes )

5/ Branchez votre téléphone ! Et entrez dans le CMD : wconnect.exe usb et il demandera un code. Ce code ce trouve dans les paramètres Développeur de votre Lumia en cliquant sur  « Coupler » puis « Entrer » dans le CMD puis « OK » dans votre Lumia. ( 30 – 60 secondes )

6/ Changez de dossier et allez dans adb et dans platform-tools et ouvrez un CMD, faites Maj + Clic droit et Ouvrir une fenêtre de commande ici. ( 5 secondes )

7/ Tapez adb devices ( 5 secondes )

8/ Placer un APK dans le dossier platform tools et faites : adb install votreAPK.apk  et patientez :)

9/ Au lancement, Votre Lumia procèdera à des ajustements. Je ne le cache pas, c’est long.

Je n’arrive pas à lancer mon application car je n’ai pas les services Google !

Et bien c’est tout simple.

1 / Téléchargez votre APK avec le lien du Google Play : http://apps.evozi.com/apk-downloader/

2/ Ouvrez le logiciel GMaps et cherchez votre application. Faites Analyze APK File. Et après un petit temps : Continue.

3/ Faites les manipulations précédentes :)

J’espère que ce tuto vous aidera :)

Attention : Si vous voulez redémarrer votre téléphone arrêtez le « mode Dev », Sinon…Tout bug…. Si vous avez une erreur   » code = 9  » essayez par Wifi. Faites wconnect.exe et l’ip de votre téléphone. ( Je viens de me taper un hard reset )

RELATED ITEMS
Author Bio

rwanito

Je me présente rwanito, et passionné de la téléphonie Nokia/Microsoft/Jolla. J'ai modifié les firmwares Symbian, créé quelques appli pour symbian. J'ai une collection assez importante passant du 3310, N95, N8, N9, 808 et comme téléphone principal un Lumia 925.

35 Comments
  1. YannWMNL

    9 août 2015 at 16 h 04 min

    Enfin un tuto en français merci :)

  2. inazuma

    9 août 2015 at 16 h 12 min

    Merci pour la partie en rouge

  3. Eric691

    9 août 2015 at 16 h 13 min

    Oui merci, je teste ça dès bientôt et je reviens en parler

  4. inazuma

    9 août 2015 at 16 h 16 min

  5. Jonathan MERLET

    9 août 2015 at 16 h 19 min

    Hello tout le monde ! je viens de réussir d’installer freelectic. Je vous en dit plus sur le fonctionnement de l’application ! merci encore Nokians pour ce tuto

  6. Pingback: [Tuto] Façon (plus simple) d’installer des applications Android sur Windows 10 Mobile | Nokians – La parole aux fans de Nokia en France et partout ailleurs !

  7. madaniso

    9 août 2015 at 16 h 30 min

    Moi j’ai un error code=1 au moment du couplage mobile/PC pourtant le raccordement est bien réussi.
    Et après quand j’installe l’APK, il me dit smartphone non trouvé, en attente… dommage.

    • rwanito

      9 août 2015 at 17 h 31 min

      Peux tu me dire quel est ton téléphone ?

    • Mica

      12 août 2015 at 13 h 50 min

      J’ai le même problème Error code = 1
      J’ai un nokia lumea 925

      • rwanito

        12 août 2015 at 14 h 41 min

        Essaye la méthode wifi toute simple.
        wconnect 192.168.x.x (l’ip se trouve dans les parametres wifi de ton tél) au lieu de wconnect usb

        • Mica

          12 août 2015 at 15 h 01 min

          Merci pour ton aide. Par contre je n’arrive pas à trouver l’adresse IP de mon téléphone pourrais tu m’expliquer comment faire ?

          • rwanito

            12 août 2015 at 15 h 14 min

            Très simple, tu vas dans les paramètres Wifi, ensuite tu cliques sur ta box (livebox, freefox…) et tu verras adresse IP, normalement qui commence par 192.168

          • Mica

            12 août 2015 at 15 h 29 min

            Ah oui celà fonctionne merci !
            Par contre je n’arrive pas à la finalité car j’ai bien l’appareil couplé mais quand je lance la commande pour installer l’apk j’ai une : « error: device not found »

  8. inazuma

    9 août 2015 at 17 h 15 min

    @madaniso es tu administateur? Et c’est quoi le lumia que tu utilise En TP

  9. rwanito

    9 août 2015 at 17 h 18 min

    Salut !
    Vous pouvez essayer la méthode wifi.
    Au lieu de faire wconnect usb faites wconnect 192.168.x.x (l’ip locale du téléphone que vous pouvez trouver sur « wifi »)
    J’ai trouvé des petites listes d’apps compatibles :
    Bank Of America (Works Perfect)

    Clash Of Clans (Works Perfect)

    MailDroid (Works Perfect and has transparent tile )

    Engadget (Works Perfect and has transparent tile)

    Snapchat (installs, Loads, Can’t Sign in)

    ZipCar (Works fine, but can’t see cars by maps and has transparent tile )

    Steam (Works perfect)

    CreditKarma (App opens seems fine, but they are undergoing maintenance atm)

    Cracked Lite (Works perfectly with Transparent tile)

    Antutu (Works perfect)

    Antutu
    Beetalk
    Bleacher report
    Candy Crush Soda Saga
    Capital One
    Citi Mobile
    Clash of Clans
    Destiny Companion App
    Facebook
    Fandango
    Feedly
    Flipboard
    Hearthstone
    Messenger
    MLB at the Ballpark
    MSGA Golf
    Ninjump
    Nook
    Odeon app
    Steam
    Tango
    Tapatalk
    Timehop
    Tinder
    Tumblr
    Twitter
    VLC
    Wikia Game Guides
    Wikipedia
    Worms 2 Armageddon
    Zipcar

  10. Djuystick

    9 août 2015 at 21 h 23 min

    Pas dispo pour le Lumia 735 ..

    • rwanito

      9 août 2015 at 21 h 44 min

      Les lumias compatibles, pour l’instant
      •Nokia Lumia 920
      •Nokia Lumia 925
      •Nokia Lumia 929 (icon)
      •Nokia Lumia 830
      •Nokia Lumia 930
      •Nokia Lumia 1520
      •Nokia Lumia 635 (1GB RAM variant)
      •Nokia Lumia 730
      •Nokia Lumia 820
      •Nokia Lumia 435
      •Nokia Lumia 928

  11. florian

    10 août 2015 at 13 h 21 min

    Je confirme qu’il faut surtout pas reboot avec le mode dev activé. J’ai un 1520 en mode brique :p. Il accepte plus mon code de verouillage. En fait je peux taper n’importe quoi aussi longtemps que je veux… Bref, je pense que j’ai plus qu’a faire un hard reset `:(

  12. rwanito

    10 août 2015 at 13 h 35 min

    Oui, je me suis fait avoir aussi.
    Le truc c’est que pour demmarer les apps il faut être en dev aussi…un point a régler 😐

  13. rwanito

    12 août 2015 at 15 h 36 min

    As-tu fais ‘adb devices’ dans le cmd du dossier adb ?

  14. Mica

    12 août 2015 at 16 h 05 min

    C’est OK ça fonctionne maintenant. J’utilisai un câble non officiel mais en utilisant l’officiel tous semble OK.

    J’installe actuellement HeartStone la console est en cours de « travail » cela semble très long. (quelqu’un sais combien de temps ?) Je vous dirais plus tard si c’est OK du coup….

  15. rwanito

    12 août 2015 at 16 h 18 min

    Si tu dois redémarrer ton téléphone désactive le mode développeur, sinon…c’est mal partie pour ton téléphone
    Du coup, j’avais redémarrer mon téléphone après avoir installe la première appli, en désactivant le mode dev, puis ca marchait après

    • Mica

      12 août 2015 at 18 h 43 min

      ça semble resté bloqué… C’est possible de fournir un lien d’une appli dont c’est sûr que cela fonctionne ?

      • samsmall

        19 août 2015 at 19 h 45 min

        as tu réussi à installer hearthstone ?

  16. Dylan

    8 novembre 2015 at 23 h 27 min

    Salut, merci pour le tuto.

    J’ai un problème au niveau du mode administrateur, en fait je ne le trouve pas.
    Quand je suis dans « Paramètres », impossible de trouver « Mises à jour et sécurité », donc impossible d’activer le mode administrateur…

    Je suis sur un Lumia 930.

    Merci d’avance pour ton aide!

    • rwanito

      9 novembre 2015 at 12 h 27 min

      Salut !
      Android n’est plus dispo dans les dernières builds.
      C’est normal de ne plus pouvoir installer d’applications android.

  17. cartone

    20 novembre 2015 at 4 h 40 min

    Oui j’ai essayé avec mon lumia 535 et ya rien à faire, j’ai vu seulement dans les commentaires qu’il ne fait pas parti de la liste, j’ai envie de le jeter ce téléphone c’est horrible

    • lumia 950

      10 février 2016 at 23 h 38 min

      le Lumia 535 ma femme la il est très bien marche super bien 1 ans qu’elle la et marche toujours aussi bien pour un téléphone a 100 € c’est super chez Android a ce prix la tu trouve une daube comme pas possible au moins tu aura des application mais le smartphone va ramer comme pas possible au bout de 3 mois tu sera revenu chez Windows quand je voit mon ancien smartphone un Galaxy S6 Edge un très haut de gamme 4 mois c’est plus le mème smartphone après cette OS vieilli mal il commençai à avoir des petit bug petit ralentissement et pas fluide clairement cette OS est un OS de bidouilleur vraiment mal optimiser celui qui me dit c’est pas vrai le mien marche bien c’est un vieux mito . C’est pas du tout normal le plus pourri des Windows phone ne rame pas c’est fluide et vieilli bien
      Faut arrêter de dénigrer Lumia et Windows 10 leur smartphone sont excellent et L’OS à rien à envier à la concurrence au contraire mise à part ses application Windows mobile 10 il est au dessus !!
      Microsoft est pour rien si les développeur font pas d’applications sur Windows c’est a eux qu’il faut en vouloir c’est des branleurs ils susse android et IOS c’est juste pas normal car c’est nous qui subissons sa et surtout sa dénigre Windows mobile alors que cette OS a un gros potentiel et est excellent pour moi je changerai plus jamais !!!! Pour des application les gens il font un cinéma c’est comme snapchat c’est anti Windows il veule rien savoir la communauté a toute essayé quand on n’est con on le reste a vie ! VIVE LUMIA ET WINDOWS MOBILE THE BEST OS FOR PHONE

  18. Gatien

    25 juillet 2016 at 13 h 14 min

    Quelqu’un sais a quoi correspond l’erreur de boostrapping 8 ? Et si oui comment y remèdier ? Merci.

  19. julia

    26 juillet 2016 at 12 h 47 min

    Salut je voulais savoir si ce tuto marche encore aujourd’hui et si oui marche t il avec lumia 640 ? merci

  20. lyrnap

    15 juillet 2017 at 0 h 00 min

    Bien le bonjour,
    Je ne sais pas si cette astuce fonctionne encore, mais je rencontre un problème dès la phase 2 :
    exécuter IpOverUsbInstaller.msi. La fenêtre ce lance sans pb, reste un moment au 3/4 du chargement et m’ouvre une autre fenêtre  » Service « Windows Phone IP over USB Transport (IpOverUsbSvc)’ (IpOverUsbSvc) failed to start. Verify that you have sufficient privileges to start system services. « . Je ne peux pas l’ancer le .msi en mode administrateur donc je ne comprend pas ou il y a un problème. Je suis le seul utilisateur/1 seul compte sur cette ordinateur. J’utilise Windows7. Auriez vous une recommandation ? Merci par avance !

    • rwanito

      15 juillet 2017 at 10 h 04 min

      Effectivement l’astuce ne fonctionne plus..
      Le mieux est du coup de ne pas installer tous ces pilotes qui ne sont plus nécessaires.
      Il me semble que le projet Android sur w10 est abandonné pour toujours, tant pis!

      • lyrnap

        15 juillet 2017 at 11 h 36 min

        Merci de ta réponse très réactive :) Je vais chercher d’autre pistes ailleurs.
        C’est vraiment dommage que ce soit aussi compliqué. Bonne continuation à toi !

  21. nico

    9 décembre 2017 at 22 h 20 min

    erreur =8 avec nokia lumia 830

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *


8 + un =

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.