Non catégorisé

Solution temporaire au bug des 4% de batterie sur votre N9

1014 views 32 Comments

Voici une solution trouvée pour corriger en partie le bug de la chute brutale de la batterie sur votre Nokia N9.

Tout d’abord, il faut que vous ayez ProfileMatic , Inception (compris dans N9QTweak ) et OpenSH d’installés sur votre N9.

Ensuite, il faut créer une règle qui s’activera quand le niveau de batterie passe en dessous de 4% :

Le contenu de cette règle sera une action personnalisée (custom action) avec comme commande à effectuer : « opensh;/sbin/stop bme; /sbin/start bme », voir photo ci dessous:

Explication: Cette commande « automatisée » va redémarrer le service de gestion de la batterie à chaque fois que le niveau de batterie bougera sous la barre des 4% (4% compris). Cela ne résoudra pas définitivement le problème mais vous pouvez ainsi bénéficier d’une information plus fiable quant au niveau de votre batterie lorsque qu’elle est située entre 40% et 0%.

En espérant que cela ai pu vous aider ; )

Author Bio

Leo

Etudiant en 5eme année d’école d’ingénieur. Grand amoureux de la Finlande depuis ma jeunesse, j'ai séjourné dans ce cher pays environ 1 an et demi. Fidèle à Nokia depuis 2005, j'ai possédé des mobiles tels que le 6131, N80, E61, N78, 5800,C7, N8, N9…

32 Comments
  1. Sébastien

    11 mars 2013 at 12 h 16 min

    Bonjour Leo

    Précieuse info , je vais tester cela , merci :-)

    Curieusement , j’ai ce problème sur mon N9 mais..pas tout le temps

  2. bob

    11 mars 2013 at 12 h 26 min

    parfait!
    moi qui va bientot prendre des vancance pour allé skiier, ce truc tombe a pic! chez moi, le froid déclanche le bug du 4% 😉

  3. Le colonnel

    11 mars 2013 at 12 h 28 min

    Une pétition à signer pour ceux qui aiment le précieux et souhaitent voir une PR1.4

    http://www.change.org/en-GB/petitions/nokia-corporation-bug-fixing-for-nokia-n9

  4. invisio

    11 mars 2013 at 12 h 58 min

    c’est quoi le bug des 4%?

    Je n’ai personnellement rien remarqué sur l’affichage de la batterie du mien, mis à part que je sais devoir me mefier lorsque je suis <30% de charge…

    • Candas

      11 mars 2013 at 13 h 53 min

      T’es à genre 23%, et d’un coup à 4%.

      Que se passe t’il si on est vraiment à 4%, le service est redémarré en boucle ?

      • Leo

        11 mars 2013 at 16 h 53 min

        Ca le fait à 4% a 3% a 2%, enfin, a chaque changement de pourcentage entre 4% et 0%, normalement.

        • David

          23 avril 2013 at 10 h 48 min

          Bonjour Léo et merci pour ce correctif temporaire.
          Par contre, je note des différences entre la ligne de commande que tu proposes (opensh;/sbin/stop bme; /sbin/start bme) et le texte dans la photo de profile matic.
          Ainsi, il y a un espace dans la ligne de commande, mais pas dans la photo, et un point virgule dans la photo mais pas dans la ligne de commande.
          Peux-tu préciser quelle est la « bonne » commande ?
          Merci

  5. Candas

    11 mars 2013 at 14 h 31 min

    Je crois qu’il vaut mieux le faire de cette manière :
    http://talk.maemo.org/showpost.php?p=1296886&postcount=885

    • Leo

      11 mars 2013 at 16 h 56 min

      Effectivement, la solution est un peu plus léchée mais c’est les memes commandes avec juste 20ms de délai entre le stop et le restart et un script pour éviter d’utiliser opensh, avec des notifs…

      Pour ceux qui veulent tenter la chose, ca sera mieux effectivement.

      • Candas

        11 mars 2013 at 17 h 06 min

        Enfaîte je dis ça parce que quand je met ta commande et je clique sur le bouton test il ne se passe rien.
        J’ai cru lire que pour enchaîner plusieurs commandes il valait mieux utiliser un script.
        Ça fonctionne le bouton test chez toi ?

        • Leo

          11 mars 2013 at 23 h 45 min

          Oui, ca fonctionne, une fois que ca chute avant la mise en place de la règle en cliquant sur test ca remonte direct :)

  6. clément

    11 mars 2013 at 16 h 38 min

    Bonjour, est-il possible de se procurer les sources d’inception et/ou un tuto sur comment l’installer ? J’ai regardé sur nokians, mais le lien donné ne fonctionne plus : https://endno.de/~itsnotabigtruck/inception/

    Merci d’avance!

    • Leo

      11 mars 2013 at 16 h 57 min

      Installes N9QTweak, inception est compris dedans :)

      • Nicolas

        11 mars 2013 at 17 h 10 min

        C’est cool ça ! Je ne savais pas… Avec Jolla je rate des choses sur le N9 :s

        • bob

          11 mars 2013 at 20 h 34 min

          +1 pour nqtweqk, ca fait un sacré paquet de chose, comme le avanced-ui et le cyclotron, donc les tuto sont dispo ici meme ….

          … en faite, il faudrai presque faire une news pour cet appli 😉

      • clément

        11 mars 2013 at 17 h 32 min

        Ok, merci! Je vais donc suivre de ce pas le tuto sur maemo.org http://forums.internettablettalk.com/showthread.php?t=80600

        • bandix400

          12 mars 2013 at 14 h 50 min

          Tu ferais mieux de faire un mixe des deux car dans leur tuto le mot de passe root est en claire dans le script « execroot.sh » :

          echo rootme | devel-su -c « $1 »

          Donc si tu as préféré changer ce mot de passe (et tu l’a préféré, t’es pas que c*n), il suffit d’un cat sur « execroot.sh » pour le connaitre … C’est assez moyen …
          opensh /restartbme.sh
          fonctionne aussi bien et semble moins pire …

          Alors le script avec opensh est-il vraiment mieux ?
          La solution opensh n’est pas bien meilleur car elle te permet de passer root sans mot de passe :

          soit un script shell sh.sh

          #!/bin/sh
          sh

          les commandes
          $ id
          uid=29999(user) gid=29999(users) groups=4(adm),20(dialout),670(pulse-access),29999(users)
          $ opensh sh.sh

          BusyBox v1.20.0.git (MeeGo 3:1.20-0.2+0m8) built-in shell (ash)
          Enter ‘help’ for a list of built-in commands.

          # id
          uid=0(root)

          prouvent que tu es passé root sans mot de passe … Une simple modif de /etc/passwd suffit pour faire sauter le mot de passe root …

          C’est vraiment très-très moyen, d’un point de vue sécurité, ce genre d’outils !
          Déjà, si tu en as un besoin aimpératif, renommes « opensh » dans un répertoire qui n’est pas dans le PATH, et vu que opensh.db ne contient que opensh d’utile, vires le packet opensh par le
          # apt-get remove –purge opensh
          qui s’impose …
          Il te suffira de mettre la commande
          /usr/local/bin sync-clock /home/user/scripts/restartbme.sh
          dans tes règles profilmatic pour espérer ne pas trop attirer l’attention …

  7. Pierre83

    11 mars 2013 at 20 h 35 min

    j’ai effectivement le problème du 4% sur mon 64 GB mais sur un autre sujet comment fait tu pour faire fonctionner ton N9 en 3G sur SFR.

    • Leo

      11 mars 2013 at 23 h 42 min

      Je suis en 2G tout le temps, a l’ancienne :p

    • Sébastien

      12 mars 2013 at 12 h 00 min

      Hello

      Même si je suis volontairement en Edge comme Leo , la 3G fonctionne avec SFR et le N9 , pas de soucis à ce niveau

      • Nicolas

        12 mars 2013 at 12 h 06 min

        Ahah, moi aussi je bride la connexion data sur mes N9… une habitude bien à nous, les N9Lovers. ^^

        • Sébastien

          12 mars 2013 at 13 h 36 min

          Et oui..Pour la réception des emails c’est bien suffisant , et la batterie nous dit merci :-)
          ..et à la maison c’est Wifi

          • bandix400

            12 mars 2013 at 14 h 15 min

            pour ceux qui ne sont pas accros aux tweet : pas de connecxion automatique au reseau mobile … Et tu l’active à la demande …

          • Pierre83

            12 mars 2013 at 20 h 25 min

            Effectivement avec SFR la 3G ne fonctionne pas, mais fonctionne très bien avec Free pourquoi si quelqu’un a une solution je suis preneur.

            Nokia et SFR c’est pas le grand amour. « Prions » pour une PR1.4

    • bandix400

      12 mars 2013 at 15 h 07 min

      j’ai juste mis la micro-puce sfr dans le N9 …

      • Red

        13 mars 2013 at 23 h 53 min

        Perso je suis passez a B&You c’est malheureux mais SFR se fiche totalement de se soucis et nokia ne fait pas pression pour autant..

        • bandix400

          14 mars 2013 at 3 h 13 min

          perso j’ai bien l’icone SFR 3G qui s’allume sur mon N9… Par contre je trouve ce N9 monis sensible que mon N900 et du coup, j’accroche moins souvent la 3G .
          Au fait, quelle solution t’a proposé Bouygues ?

  8. Cys06

    11 mars 2013 at 21 h 16 min

    Utilisez vious l’économiser de batterie sur mode automatique ?
    Le bug apparaît chez moi , et j’avais ce mode active à 20 % .
    Je l’ai désactivé , et je n’ai plus eu de bug des 4%.pour l’instant du moins.

    • Leo

      11 mars 2013 at 23 h 42 min

      Non, je n’utilise pas ce mode..

    • Corto Maltese

      3 février 2014 at 0 h 12 min

      Je découvre le site, désolé pour la réponse tardive.
      Je n’ai jamais eu ce bug des 4% : comme Cys06 et Leo, je n’ai jamais utilisé le mode ‘Automatique’, uniquement le mode ‘Activé’

  9. bandix400

    12 mars 2013 at 14 h 15 min

    pourquoi inception ?

  10. tristan6661

    18 mars 2013 at 18 h 05 min

    Bonjour,

    OpenSH s’installe en mode root :

    /usr/sbin/incept opensh_armel.deb [validez]
    Password : rootme[validez]

    Merci d’avance…

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *


6 − = un